
Just a reminder:

You can use the Search button to find help topics by their keywords. You can browse though a
help group with the Browse buttons.

Use the tab key and press enter, or click on the following Help Groups:

Main Information

Menu Commands

Forms



Information

Video Library is an open application written in Visual Basic 3.0 (Professional Edition). My 
intention is to distribute this software freely. Anyone who wishes may use it, or even make 
modifications to it. If you like, you may forward notes to me about changes you've made. The 
idea is to have fun, and to share our skills. My hope is that we may all broaden our scope of 
experience, and enjoy ourselves in the meantime. If you do send me notes about changes, make 
sure you include the source as ASCII text. This will allow support for future versions of Visual 
Basic. You can reach me through America Online as RStauch, or by mail:

Richard Stauch
c/o SHL Systemhouse
12750 Center Court Drive
Suite 700
Cerritos, Ca. 90701-4566

Disclaimer

Of course, there is no warranty (express or implied) on this software. State regulations 
notwithstanding, I do not guarantee that this program will work under any circumstances. I hope 
it will, but I can't know that. Besides, you get what you pay for, and this software is free!

Reminder

Use the Search button to find specific help topics in this file. You can use the Browse buttons 
to scroll through the help topics in the current group.



Application Description

I intend Video Library to be a simple application. For that reason I've left out several features 
that most people would agree are indispensable to a database management system.

One would be a record selection feature. This would allow one to sort records on criteria other
than the Title of the video. Then one could select only records with certain data, or data within a 
certain range. Such a feature would complicate an application, and that's contrary to my 
intentions.

Another feature I left out is to allow one to edit data within the grid control of the search 
form. This would be a powerful feature, but would also make the application programming 
complex!

The purpose of this application is to allow others an opportunity to make or suggest 
modifications. We would build the application together! I think this is a new idea, and I like it. 
Let me know what you think.



Edit Tables

There are three tables defined in theVideo Library database. The tables are linked through 
code fields.

The main Video table has the Title, ISBN Code and the other fields usually associated with a 
video tape. The Maintenance command button in the initial window opens a form to modify 
records in this table.

The Genre table has the texts of the various story categories that you can associate with a 
video tape. Select Genre from the Edit menu to modify records in this table.

The Rating table keeps the texts of the movie ratings for your movie titles. You can maintain 
standard movie rating codes, or invent your own.

You cannot delete Genre or Rating records if they are in use. Review the Video records to 
determine which records have the code you want to delete.



Richard Stauch

PROFILE

Richard Stauch has experience in facilities management, software and hardware 
maintenance, and the project life-cycle. He has experience with a variety of computer 
languages in several of the most popular environments. He has a broad experience 
designing screen displays, reports, data files and programs. He has a wide knowlege of 
AS/400 architecture and system resources. Also, being a hobbyist he continues to work 
with computers even off-duty.

EXPERIENCE

1993    Present: Associate Systems Engineer
SHL Systemhouse
(Formerly with ABS)

1990    1992: Computer Systems Supervisor
United Warehouse & Distribution Corp.

1988    1990: Assistant Dispatcher
Weber Distribution / Weber Truck & Warehouse

EDUCATION

1991    1992: Certificate Program / Computer Technician
NRI School - McGraw/Hill

REPRESENTATIVE PROJECTS

With ABS and SHL Systemhouse, Richard Stauch has worked at several facilities, 
providing facilities and project management services. He has tuned systems for 
performance, installed resource usage reporting, security management and batch 
automation. The companies where he has been assigned encompass a variety of 
industries.

While employed by United Warehouse, Richard Stauch ran a one-man shop, managing 
the entire facility's computer systems. This involved many large and small projects of 
hardware and software upgrade and maintenance in several platforms. He had sole 
responsibility to debug and modify warehouse, EDI and reporting software.

At Weber, Richard Stauch programmed office PC's to automate time reporting processes 
that had formerly been done by hand. This saved the company up to $10,000 per year in 
supervisor time. Additionally, he created an application to automate manifest generation 
for trucking operations.



Richard Stauch

RELEVANT EXPERIENCE

ABS / SHL Systemhouse Associate Systems Engineer
1993 to Present

Richard Stauch installed and set up Software/2000 on 
the AS/400 for the accounting department of Aero 
California, a comercial airline based in La Paz, Mexico.
He set up and automated a resource-reporting program. 
He seperated remote controllers into their own 
subsystems to prevent system down-time from 
becomming a system-wide problem. He tuned the 
system memory pools for optimal performance.

While assigned at Delta Technical Coatings in Whittier,
Richard Stauch tuned the AS/400 for perfomance. He 
installed Rumba/400 on several office PC's with PC 
Support/400 communication routers. He performed 
analysis and programming services maintaining 
Software PM programs. He designed and installed 
backup automation using save-files. He seperated batch
processing for department users into subsystems.

Richard Stauch performed analysis and programming 
services at United Warehouse on several occasions for 
EDI processing, stock rotation and trucking master-bill 
generation.

United Warehouse Computer Systems Supervisor
1990 to 1992

United Warehouse hired Richard Stauch to assist their 
vendor with software maintenance for their Warehouse 
Management System. During his employment he tuned 
the system for optimum performance, set up system 
security and upgraded the AS/400 hardware. He 
enhanced the EDI implementation written in CL and 
RPG/400. He then installed a network connection to 
IBM InfoNet, and automated the EDI process using 
data queues. He installed a connection to a remote 
workstation controller in Columbus, Ohio and trained 
the users there in use of the WMS system. He designed 
and programmed the truck master-billing process. Also,
he designed and programmed the UPS vs RPS carrier-



assignment process.

Weber Distribution Assistant Dispatcher
1988 to 1990

Richard Stauch performed all the duties of a night-shift 
dispatcher, including carrier-claims management. He 
also used DBase III+ to automate the generation of 
driver manifests. He simplified the warehouse work-
time reporting process using DBase and Lotus, 
replacing a manual procedure.

Richard Stauch

TECHNICAL EXPERIENCE

Application 
Experience

Warehousing
Distribution
Manufacturing
Financial
Aircraft Maintenance

Hardware 
Experience

Computer
IBM PC/AT
286 / 386 / 486
AS/400

Systems Software
DOS (through 
6.0)
Novell Netware 
v3.11
SCO Xenix
OS/400 (through 
2.3.0)

Software Experience Languages
Visual Basic 3.0 
Pro.
Quick C / Windows
Turbo C / DOS
Quick Pascal / DOS
Quick Basic / DOS
CL/400
RPG/400
PC Support/400
Rumba/400

Applications
Lotus 2 & 3.1+
Excel 4.0
WordPerfect 5.1
Word / Windows 
2.0
DBase III+
Software PM
Software/2000
GenTran/400

Technical Courses Structured Systems Design
Structured Development
Electronic Data Interchange Programming



GenTran/400 Mapping
Microcomputer & Microprocessor Technician



File Menu Commands

The File menu groups commands that operate on the database files. You can Select a file to 
edit, Copy one file to another, Print data from the current file or Repair a file. When you're 
through using this application, select the Exit option.

Select

Copy

Repair

Print

Exit



Select File Command

The Select File command uses the common dialog box in Open File mode to choose a file. 
Select the drive and directory you want to use, then select the file name you want from those 
listed, or type a file name to create. You must use the extension MDB, because we use the Access
1.1 database format.

You can keep several files in different directories or with different names. This way, you can 
organize your Videos in any way you choose. Later, you can use the Copy file command from 
the File menu to append data into other files.



Copy File Command

Use the Copy File command to create new files based on the current file or any other existing 
database file. An Options button on the form allows you to select various criteria for copying.

You can keep data separated in different files, based on any criteria you choose. At any time, 
you can combine separate files by appending several smaller files together.



Repair File Command

Whenever you feel access to the Video database is too slow, it may be that the index has 
become very complex. Also, you may believe the database has become corrupted. In either case, 
use the Repair command to reorganize and reset the database. The function will save a backup 
copy of the original database with the extension BK.

A dialog is displayed to ask if you want to repair the currently selected database file. Click on 
OK to continue the operation, or Cancel to abort it.



Print File Command

There are two report forms available. The Short report shows Video titles, ISBN codes and 
certain other data. The Long report shows everything, including the Synopsis. This can be a very 
long report. The Print command uses the currently selected report form. To change this, use the 
Preferences command on the Options menu, or click on the Preferences command button.

The Print command directs output to the current default output. There are three output 
directions you can send reports to. The Window output direction will display output in a window.
From this window you can send the report to a printer. Or, you can direct output directly to the 
printer, or to a file. As above, use the Preferences command to change this default.



Exit File Command

When you're finished editing your data, select the Exit option from the File menu to quit. This
ends the program and closes all of the forms. The Exit button uses this menu command by 
default.



Edit Menu Commands

Edit menu commands open forms for adding, deleting or modifying data in the Genre, Rating 
or Video tables. These tables are located in the currently selected database file.

Genre

Rating

Video



Edit Genre Command

You can keep a list of plot types (Action, Biography, Musical, etc.) in the Genre table. The 
Code field must be unique, and cannot be blank.

This command brings up a generic form which is also used by the Rating command. Since the
tables are identical in structure, we change the controls on the form to bind to the correct fields.



Edit Rating Command

You can maintain a list of movie ratings ([R] Restricted, [G] General Audiences, etc.) in the 
Rating table. The Code field must be unique, and cannot be blank.

This command brings up a generic form which is also used by the Genre command. Since the 
tables are identical in structure, we change the controls on the form to bind to the correct fields.



Edit Video Command

The Video command on the Edit menu displays the Maintenance window. Here you can edit 
the data in the main Video table, and search through the data.

The Maintain button on the initial form uses this command by default.



Options Menu Commands

The Options menu has one selection; Preferences.

The Preferences command of the Options menu allows you to select the default file name and 
path, as well as the report form and output location.



Help Menu Commands

Start the Windows Help engine in various ways with the options in the Help menu. Also, you 
can display the About dialog box. Once in the Help system, you can browse back and forth 
through the informational groups with the browse buttons. Use the Search feature to look up 
topics by keyword.

Contents

Main

Using Help

Author

About



Help Contents Command

Start the Windows Help engine by clicking on the Contents option of the Help menu. This 
displays the first help context in the help file. The Help command button on the initial form uses 
this command by default.



Help Main Command

Read about this application by clicking on the Main option of the Help menu. This displays 
the history and intent of this program.



Using Help Command

Get Help on the subject of using Help by clicking on this command. This shows the Windows 
Help topic "Using Help".



Help Author Command

Click on the Author option of the Help menu to display information about the author of this 
application; me. There are three topics in sequence, created from my resume. Use the browse 
buttons to scroll through them.



Help About Command

Display the About dialog box by clicking on the About option from the Help menu. The 
dialog displays the version of this application, and information about the current Windows 
session.



Form: Copy

The Copy form allows you to copy data from one file to another. You control which table(s) to
copy, and if you will Append data to the existing file, or Replace it.

Select the file to copy from by clicking on the From command button. By default, the current 
file is selected to copy from.

Click the To command button to select the file you want to copy to. This also defaults to the 
currently selected file.

Choose copy options by clicking on the Options command button. This command displays a 
dialog box where you select the tables to copy, and if you want to Append or Replace data in the 
To file.

When you're ready, click on the Copy command button to perform the function. If the From 
and To files are the same, you'll get a warning. If the To file doesn't exist, this function will ask if
you want to create it. Click on OK to create a new file, or Cancel to stop the copy operation.

When you're finished, click on the Done command button.



Form: Copy Options

Set the options for copying in this form. You can select to copy one or all of the tables with 
the check boxes labeled Genre, Rating and Video. If you want to replace the data in the 
destination table(s), click on the Replace radio button. Otherwise, select the Append option.

You can copy the tables individually. That way, you can append one table and replace another.



Form: Maintenance

Edit the Video table using this form. Most of the data can be changed directly on this form. 
Edit the Synopsis of the Video by clicking on the Synopsis command button.

You can review the file in a grid form by clicking on the Search command button. If you 
change the current record on the grid, that will be the record on this form when you return.

There are several input boxes, and a collection of command buttons on this form. See help on 
these subjects for details.



Form: Maintenance: Data

There are several data elements on this form. The text boxes are not case-sensitive.

The ISBN code is a key field. Blank is not a valid entry, and it must be unique. The field is not
case-sensitive, so "ABC", "Abc" and "abc" are equivalent.

Title is the primary key field, so it also cannot be blank, and it must be unique.

The Genre and Rating drop-down list boxes represent the texts of the codes in the Video 
record. As a new record is read from the Video table, the codes are searched in the Genre and 
Rating tables, and the corresponding text is highlighted in the list boxes.

The Running Time is in minutes, and the Release Year is a four-digit year the video was 
released, or originally aired. The spin buttons next to each text box increment or decrement the 
values in them.

The one-character fields Chromaticity and Recording are manipulated through radio buttons 
in frames. Selecting one of the buttons within the frames changes the code in the corresponding 
field.

To edit the Synopsis, click on the Synopsis button.



Form: Maintenance: Controls

The various controls on the Maintenance form allow editing the Video table. You can also 
scroll through the file.

The Add button creates a new blank record in the Video table. After entering the Video data 
you want, click the Update button. To abort the Add function, click on the Done button.

After editing the current record, click on the Update button. Also, if you scroll to another 
record in the table, this will automatically update the record.

Delete a record by clicking on the Delete button. The record will be completely gone, 
including the synopsis, so be careful!

Scroll through the table with the data control. The outside buttons take you to the first or last 
record in the table.



Form: Grid

Search through the Video table with this form. Double click on any row to make that record 
current. The records aren't editable in this form. Make a record current, then click on Done to 
return to the Maintenance form.

Click on the buttons marked "<" and ">" to page back and forth through the Video table. 
These controls aren't a normal part of the data control. You'll find these buttons positioned to 
either side of the data control.



Form: Synopsis

Edit the synopsis of the Video record in this form. The Synopsis is a memo field, so it can 
hold an enormous amount of data. You can enter any kind of information in any format you 
choose. Just remember that it will all print on the Long report form!

Enter any text you like in the large text box. You can use the editing keys to move around in 
the box, and to select text for editing. When you're done, click on the Done command button. To 
cancel your changes, click on Cancel.



Forms: Genre and Rating

Whether you select Genre or Rating from the Edit menu the program opens the same form. 
The menu option sets a global variable. The form uses this variable to modify labels, and the data
control binding.

Enter a unique 1-character value for the code field. The text value can be up to fifty 
characters. The data control lets you scroll through the table. To add a new record, click on Add, 
enter your data, then click on Update. To remove a record, click on Delete. The program will 
verify the code is not in use. If so, the record will not be removed.



Form: Default Preferences

Use this form to select the path and file you want to open by default each time you run this 
program. Click on any of the labels in the path and file areas, or on the command button next to 
them with the elipse ("..."). This will show an "Open File" common dialog box for you to use. 
Also, you can select the report form and output direction you want to be the default with this 
form. Just click on any of the labels, or on the command buttons next to them with the caption 
"<". These will cycle through all the valid choices for you.

The options you select here are recorded in the information file (VidLib.INI). If you wish, you
can use any text editor (such as Notepad) to modify this file externally to this application. If you 
do, use a file name with the extension .MDB, and be careful not to use a path name that doesn't 
exist. We use the Access database engine which requires this extension, and the system will not 
automatically create a new path. Neither will it create the file as it does when you use the Select 
command on the File menu. Also, be certain not to indicate reports that don't exist, or invalid 
output directions. The Print command won't know how to handle that.



Form About Dialog

The About dialog box displays the title of this application and the version. It also diaplays 
some information about the current Windows session. This includes the version of Windows, the 
running mode, the amount of free memory in Kilo-bytes and the amount of free system resources
as a percentage.

There are no input-capable controls on this form. Only the OK command button, which 
allows you to return to the main Video Library form. Also, the Video Library Icon picture-box 
will bring up the Contents topic of this Help file when you double-click it.



Search Help

This is the Search help topic. Click on the Search button to restore the dialog box, or select an 
item below.
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